ワイヤード・パンチ

ブルースクリーンや強制シャットダウンが頻発する原因は、グラボの可能性大。

グラボ一つ買い替えただけで、時間もお金もドブに捨てる、散々な数ヶ月を過ごすハメになってしまいました。

以前使用していたPCのパーツ構成。

今回の件では、途中でグラボ以外のパーツをすべて買い替えしています。

PC買い替え前でも後でも異常は発生しており、まずは買い替え前の状況からです。

問題のグラボ。

今回の問題のグラボです。玄人志向の「GF-GTX1650-E4GB/OC/DF」。

GTX1650のグラボの中では、おそらくもっとも安物。

その他のパーツについて。

  • PCケース: SilverStone SST-ML08B
  • マザーボード: MSI H110I PRO (チップセット: H110)
  • 電源: SilverStone SST-SX500-LG (規格: SFX-L、容量: 500W)
  • CPU: Intel i5-6500
  • CPUクーラー: SilverStone SST-AR06
  • メモリ: Corsair CMK16GX4M2A2666C16 (8GB×2)
  • SSD: CFD CSSD-S6T128NHG6Q (128GB、2つ装着)
  • HDD: Western Digital WD10EFRX (1TB、1つ装着)

グラボだけは新しいものですが、その他のパーツはもう購入してから4年以上経過しています。

旧PCにおいて、シャットダウン発生時の状況。

フルスクリーンでゲーム中に突然、ディスプレイが何も映らなくなる現象が発生するようになりました。

グラボを買ってからすぐというタイミングではなく、3ヶ月経ったくらいのころです。

負荷の高いモダンウォーフェアをプレイ中だけ発生すると思っていたのですが、それよりも負荷の低いコイカツでも発生するので、ゲームであれば発生するような感じです。

グラボのファンも停止しており、ディスプレイに何も信号が出力されていませんが、PCの電源は入ったままの状態です。

さらに厄介なのが、ただPCを再起動するだけでは復旧せず、なぜかグラボをいちいち挿し直さないと復旧しないという、とんでもない状態でした。

しかも、挿し直しで必ず復旧するというとそうでもなく、何度挿し直してもなかなか復旧しないこともありました。

なお、平常作業時にはシャットダウンが発生することはありませんでした。

旧PCで試したけど、解決に至らなかったこと。

以下のことを試してみましたが、結局またシャットダウンが発生しました。

温度確認。

HWMoniterを使用してみたけど、とくに高温にはなっていなかった

PCのフタ開けっ放しで起動。

そもそも高温でないため意味無し。

ホコリの除去。

そもそもあまり溜まってなかった。

グラボのドライバ再インストール。

ビデオカードドライバ削除の専用ツール DDU (Display Driver Uninstaller) – ぼくんちのTV 別館

DDUを使ってアンインストールしてから、もう一度インストールしても効果なし。

dxdiagを確認する。

とくに異常なし。

デバイスマネージャでグラボのプロパティを確認する。

とくに異常なし。

NVIDIA Inspectorを使用する。

PC ゲームで OS 巻き込んでフリーズしたり、ディスプレイドライバーの応答停止と回復でゲームがクラッシュしてまともにゲームできない場合の対処方法 – awgs Foundry

上の記事を参考に、NVIDIA Inspector で Power and Temperature Target の値を100%から60%に落としてみたけど、効果なし。

電源を交換した。

電源の劣化が原因との意見もありますが、効果なし。

せっかく新しい電源を買ったのに、ドブ金になってしまいました。

CMOSクリアした。

マザーボードに付属のジャンパピンを紛失してしまったため、ドライバをピンにあてて実行しました。

しかし効果なし。

そもそも、正常に実行できているのかどうかわかりません。

メモリ診断ツールを実行した。

「スタートメニュー」→「Windows 管理ツール」→「Windows メモリ診断」

まずは上記を実行します。

終了後、下記へ進みます。

「イベント ビューアー」→「Windows ログ」→「システム」

そこからソース「MemoryDiagnostics-Results」を探します。

しかし結果は「Windows メモリ診断によりコンピューターのメモリがテストされましたが、エラーは検出されませんでした」と書かれていました。

メモリを減らして起動してみた。

メモリが2つ装着されていたので、片方だけ外してPCを起動してみました。

しかし、今度はPC自体が全く起動しなくなってしまいました。

メモリを2つに戻しても、SSDを1つに減らしても、グラボを抜いてもダメ。

電源を入れると、マザボ上のDRAMと書かれた赤いランプが点灯するようになってしまい、それっきり何をしてもBIOS画面すら立ち上がらなくなってしまいました。

メモリをいったん外しただけなのに…。

効果なしどころか余計に状況が悪化してしまい、結局このあとの新しいPCへ買い換えるハメになってしまいました。

ただ、この時点ではグラボ以外が故障していた可能性も捨てきれません。

メモリかもしれないし、マザボかもしれないし、CPUかもしれないし…。

電源だけは問題ないことは間違いありませんが。

新しいPCの構成。

  • PCケース: Thermaltake Versa H18 CA-1J4-00S1WN-00
  • マザーボード: BIOSTAR B450GT3
  • 電源: Thermaltake TR2 500W V2 GOLD PS-TR2-0500NPCGJP-G-V2
  • CPU: AMD Ryzen 3 3200G
  • CPUクーラー: CPU付属のもの
  • メモリ: G.Skill F4-2666C19D-16GNT
  • SSD: レキサーメディア NM610 LNM610-250RBJP
  • HDD: 東芝 DT01ACA100

グラボなしのPC一式を新たに購入し、そこに以前から使っていた玄人志向のグラボを付け替えました。

これで安泰かと思われましたが、まだまだ災難が続きました。

新PCにおいて、ブルースクリーン発生時の状況。

いきなり画面が映らなくなってしまう現象は起こらなくなったものの、代わりにブルースクリーンが発生するようになってしまいました。

今回はゲーム時だけに限らず、平常作業であってもです。

ブルースクリーン時に表示されるエラーコードや、イベントビューアーでKP41のBugcheck codeを確認しても、毎度エラーコードがバラバラであり、そこから原因を特定できません。

新PCで試したけど、効果なかったこと。

グラボのドライバを再インストールした。

CPUがAMD製のRyzenであるためか、初めからRadeon Softwareがインストールされていました。

nVidiaのグラボを使っているのに、GeforceとRadeonの2種類のドライバが共存しています。

これがまずいのではないかと思って、Radeon SoftwareはAMD公式ツールを使ってそのまま削除、nVidiaのドライバはDDUでアンインストールしたのち、入れ直しました。

しかし、再度ブルースクリーン発生したため、効果なしです。

高速スタートアップを無効化した。

効果なし。

そもそも有効にしたところで、速度の違いを感じない。

メモリ診断ツールを実行した。

効果なし。

BIOS設定を変更した。

ブルースクリーンが発生する前、B450GT3のBIOS画面にて設定を変更していました。

それ以降に、頻発するようになりました。

「Advance」→「ACPI Setting/WakeUp Event control」→「EnP Control」

上記の値を「Disable」から「Enable」に変更していました。

その理由ですが、電源をオフにしても、電源ケーブルを抜かない限り、LEDが赤く光り続けるためです。

これでは寝るときの妨げになりますし、いちいちケーブルを抜くのも面倒です。

かといって、ブルースクリーンが発生していては、それの方が問題です。

やっぱり「Disable」に戻したところ、ブルースクリーンはピタリと収まり、これで解決かと思われました。

しかし、ひと月たった頃にまたブルースクリーン再発。BIOS設定は無関係だったかもしれません。

なお、後述しますが結局グラボを外すことになり、それならBIOSを変えても問題ないと思って、再度ErP Controlを有効にしてみました。

すると、ブルースクリーンこそ出なかったものの、なぜかChromeのサイト表示が突然グレーのエラー画面になったり、落ちてしまう現象が頻発。

このマザボも、なんかおかしいと言わざるを得ません。

そもそもこのグラボの、BIOSTARというメーカーの製品に関する情報が、なぜかぜんぜん出てこないのです。

ASUSやASrockやMSIなら、いくらでもBIOS設定の情報が出てくるのですが…。

そのため、BIOSのいじるべき箇所も合っているのかわかりません。

結局、グラボが不良品だった恐れあり。

BIOS設定をいじってないうえに、グラボ以外の他のパーツは新品。

このパーツ構成のままでは、これ以上対策しようがありません。

よってもうグラボを抜いて、オンボードで起動せざるを得ませんでした。

すると、オンボードで起動以降、ブルースクリーンは一度も発生しなくなりました。

このことから旧PCでも新PCでも、グラボが原因だったと言えるでしょう。

ただ、オンボでも通常の作業なら問題ないものの、ゲームするうえでは力不足です。

よって、新しいグラボをただいま注文中です。

もしその新しいグラボを数ヶ月使い続けてブルースクリーンが発生しなければ、以前のグラボが壊れていたと断定できます。

なお、新しいグラボはRadeonのRX560にしておきました。

旧式であるため、GeforceのGTX1650どころか1050Tiよりも性能は劣るそうですが、CPUと同じAMD製であるため、いちおう合わせておくことにします。

Radeonで補助電源なしのものが、今のところRX560までしかないので、これで我慢せざるを得ません。

なぜ補助電源なしが良いかというと、PCの中身をあちこちいじくって、以前のPCみたいにもう壊したくないからです。

まとめ。

買ってまだ数ヶ月しか経ってないグラボだから、異常の原因は他にあると思いこんでいました。

そのせいで、原因を特定するまで、無駄な遠回りに。

結局は、その新しめのグラボだと確定。

新品であっても、ものによっては油断できないということです。

あと、PCの組み換え中、あまりにもイライラが半端ではありませんでした。

私には、組み立てという作業にまるで楽しみが見いだせないようです。

(大昔にやったプラモ制作も、正直言ってめんどくさいとしか思えませんでしたしね…。)

よって、新PCは代行で作成してもらいました。

グラボだけ旧PCから引き抜いて、自分の手で後付けですが、それ以外のパーツはきっとうまく組んでくれたでしょう。

ただ、パーツは完全におまかせであったため、BIOSTARとかいう知らないメーカーの粗悪品に当たってしまいました。

そのせいで、今回の主題であるグラボの問題だけでなく、BIOSの問題にも当たってしまうことに。

組み立ての腕前がなくてもパーツの知識があるなら、代行の際にそのパーツを指定した方がいいですが、そうでないならもはや、BTOなどで完成品を買った方が確実でしょう。

お値段としては、自分で自作 < 自作代行 < BTO となりますが、時間や手間に関してはその逆です。

以下、結論。

  • 玄人志向とBIOSTARの製品は、もう二度と買わない。
  • 自作PCは、もう二度とやらない。やるとしても、代行で。
  • ブルースクリーンや強制シャットダウンが出たら、まずはグラボを疑え。

追記。

グラボ一つですべてが狂った。自作PCはもう二度とやらない。

上の記事にも書きましたが、新しいグラボが届いたのですが、それでもブルースクリーンが発生…。

このことから、新しいPCはマザーボードも不良品であると断定できます。

もう自作は信用できません。BTOから完成品PCに買い替えました。

そのBTOのPCは、今のところ問題なしです。