ワイヤード・パンチ

サイトレイアウトを変えてみました。よろしければアンケートにご協力ください。

TMPGEnc Video Mastering Works 6、起動直後にエラーが出てしまい起動できないときの対処法。

動画の編集や変換にたいへん便利なこのTMPGEnc。何週間か前まではとくに問題なく起動できていたのですが、突然起動に失敗するようになってしまいました。

結論としてはグラボのドライバに原因があったのですが、エラーに至るまでの経緯や解決法をメモしておきます。

広告

エラーに至るまでの経緯。

TMPGEncを起動している最中に、突然のエラー。そして強制的に終了。ただそれだけ。

というだけではあまりにお粗末なので、もう少し詳しい流れを説明しておきます。

まず起動した直後には、ロゴ画面が表示されます。そのロゴ画面で初めに行われる手順は、ライセンスの確認です。

なお、今回利用しているのは体験版ではなく、ちゃんと購入した製品版です。バージョンは6.2.4.31

久々に起動するとライセンスの再入力が求められますが、初めから入力ボックスに入力されているので、そのままOKで進めます。

特に問題なくライセンスの確認が取れました。次回以降は確認されませんし、確認できたということはネット接続にも問題なしです。

次は「アプリケーションの初期化中….」というメッセージとともに、ロゴ画面上の緑の進捗バーがぐんぐん伸びていきます。

そして最初に貼った写真の位置までバーが来ると、しばらく固まったのちに、Windows側による「TMPGEnc Video Mastering Works 6 は動作を停止しました」というダイアログが出現

「この問題の解決策を確認しています…」というメッセージも一瞬表示されますが、特に何も見つからないまま終了です。役に立った試しがありません。

アプリ側によるダイアログではなく、Windowsが突然終わらせてくるため、何が原因か教えてくれないまま。

以前は問題なく使えていたのに、本当に困りました。動画編集はこれがもっとも使いやすいし、高いカネ払って買ったものですから、何とか直ってほしいところです。

思い当たる原因。

これが原因かどうかははっきりしませんが、グラフィックボードを新しいものに買い替えてから、このエラーに出くわしやすくなったように想います。

以前の記事でも書いたように、かつては「MSI GTX 950 2GD5 OCV2」というグラボを使っていましたが、そのときは今回のエラーに全く遭うことなく、正常に起動していました。

ただ、そのグラボが壊れてしまったため、しばらくはグラボを外して、オンボードでPCを使っていました。解像度は落ちたものの、オンボードでもTMPGEncは問題なく起動しました。

なお、オンボードのグラフィック性能は、マザーボードに影響されるはずなので、いちおう今使っているマザーボードを挙げておくと、同じくMSI製の「H110I PRO」です。グラボと同じメーカにしておいた方がいいのかなと思って。

でも、オンボードでやっていくのはいろいろと限度があるので、新たにグラボの買い替えを決意。ただ、そんなに予算がないため、現行の1000番台の中でも最も安い、ASUS製の「GT1030-SL-2G-BRK」にしておきました。

GTXではなくGTなので、ゲームに関する性能はぶっちゃけGTX950に劣るのですが、ファンレスかつコンパクトなボディで4Kが実現できるので、手っ取り早く4K環境を手に入れたいなら選択肢になり得るグラボです。

紹介はさておき、このGT1030のグラボに買い換えてから、TMPGEncに異変が起き始めたように想います。

先月末に買い替えてから初めてTMPGEncを起動したときも、今回の件と同じエラー。ただ、そのときは何度かアプリを再起動しているうちに、無事に起動できたのです。

起動できたとはいえ、正確なメッセージは覚えていませんが、起動直後に「NVENCが使えない」といった感じのメッセージは出てきました。

よくわからなかったので、そのときは読み飛ばしましたし、ただ動画から不要な部分をカットして変換をかけるだけの処理は無事に完了しました。

ところが昨日、また動画を編集する必要があったのでアプリを起動すると、月末のときとは違って、いくらアプリの再起動を繰り返したところで、先へと進むことができないのです。

アプリの再インストールも試したのですが、結果は同じです。

なお、これがアプリのバージョンによるものなのかは不明です。月末と昨日の時点で、バージョンが同じだったかどうかは覚えていません。

過去のバージョンも試したいところでしたが、公式サイトからでは最新版しかダウンロードできません。

何か怪しげなサイトを探って、海外版の過去バージョンの体験版なら見つかりましたが、そちらで試してもやっぱり起動時の初期化中のところでエラーとなってしまいました。

もうお手上げです。サポートにこの件を連絡してみたので、あとは有益な回答を待つしかありません。

余談。

ちなみに今回やりたかった作業は、動画から不要な部分を切り取ってYoutubeに上げるだけなのですが、Youtube上でも動画を切り抜きくらいならすることができました

ただ、アップロード済み動画から切り抜きが反映されるのに時間を要するため、やはりローカル環境であらかじめ切り抜きしておくことが望ましいです。

GT1030ではTMPGEncの使用に適さないのでしょうか?ともかく、何らかの反応を早くいただきたいところ。

追記。解決法について。(2017/9/19)

サポートから返信が来ました。以下、長くなりますがメールの内容を引用します。

お知らせいただきました状況から、ビデオカードに関連する処理を行わない起動をお試しいただいた場合に状況変化が無いかご確認をお願いできればと存じます。

もし宜しければ、以下の設定をお試しいただけますとありがたく存じます。

■NVIDIA社製ビデオカードの機能「CUDA」へのアクセスを行わない方法
デスクトップ上に作成されたTMPGEnc Video Mastering Works 6のショートカットアイコンを右クリックし、プロパティを選択します。
その中に「リンク先」という記載がありますが、標準状態では以下のように記載されております。

“C:\Program Files\Pegasys Inc\TMPGEnc Video Mastering Works 6\TMPGEncVMW6.exe”

この状態に対し

“C:\Program Files\Pegasys Inc\TMPGEnc Video Mastering Works 6\TMPGEncVMW6.exe” –nocuda

上記のように末尾に半角スペース・ハイフン・ハイフン・nocuda を書き加えてから「適用」していただき、再度このショートカットからTMPGEnc Video Mastering Works 6を起動頂きます。

上記で起動可能となりました場合には、ご使用の環境のビデオカードやドライバに何らかの異変が発生し、弊社製品のように機能の準備を行う際にエラーが発生している状況と考えられます。

お手数ではございますが、以下のNVIDIA社のページから最新のドライバをダウンロードいただき、一旦現在のドライバーをアンインストールされた後に当該の最新ドライバのインストールで、改善が無いかお試しいただけないでしょうか。

■NVIDIA GT1030 用 Windows10 向けドライバ「Ver.385.41」
http://www.nvidia.co.jp/download/driverResults.aspx/123541/jp

※アンインストールの際、映像・音声のドライバのアンインストールの他に「NVIDIA GeForceExperience」や「NVIDIA PhysX」等の同時にインストールが行われるビデオカード用ツールも併せてアンインストール頂ければと存じます。
※最新版のインストールの際には『カスタム』を選択し『クリーンインストール』を選択され、映像、音声のドライバーの他のツールがご不用であれば、チェックを外し、インストールしないように設定頂いてから、作業進行頂ければと存じます。

ドライバのインストール後、上記で設定頂いた「–nocuda」を削除いただき通常の起動状態で改善があるかご確認頂けないでしょうか。

順番どおり、まずは「CUDA」というものを無効化する手段を試してみます。

その「CUDA」というものが何なのかはさっぱりわかりませんが、ひとまず気にせずに進めます。

ショートカットのプロパティからリンク先の末尾に「–nocuda」を追記してから、TMPGEncを実行。すると、今まで起きていたエラーがウソのように、何のエラーも出ることなく起動することができました。

ただメールにあるとおり、こうなった場合は異変があるということ。完全な解決とはなりません。

「–nocuda」をしない、いつもの起動の結果もいちおう気になるので、リンク先を元に戻してもう一度起動。

すると、「CUDA」を使っている状態でも、なぜか起動できました。しかし、先日まではなかった以下のメッセージが出るようになりました。

NVENC エンコーダーのチェックを行えなかったため、使用できません。
アプリケーション起動時に NVENC エンコーダーが使われていないようにしてください。

その「NVENC エンコーダー」とかいうのも何者なのかさっぱりわかりませんが、どちらにしろ異常であることには変わりないでしょう。

次に試した手順は、グラボのドライバのクリーンインストール。いつもなら上書きでアップデートするところを、いったん完全に削除してから、再度インストールするということですね。

ひとまず最新版のインストーラーを実行すれば、簡単にクリーンインストールはできます。

そしてインストール完了後、先程のリンク先も「–nocuda」を付けたままではないことを確認し、もう一度TMPGEncを実行。

その結果、今度こそちゃんと何のエラーも出ず、「NVENC エンコーダー」のことも言われず、無事に起動することができました

念のためアプリの再起動を繰り返しましたが、いずれも正常に起動できました。

以上のことから、グラボがまず原因であったことは正しかったようです。ただ、なぜドライバに異常が発生したのか、そこまではわからず。

そして、困ったときには再インストールというのは鉄則ですが、グラボのドライバを再インストールすることは忘れていました。

とにかくこれで、安心してTMPGEncを使えるということです。サポートの方へ、非常に丁寧な解説、ありがとうございました。